Problem with Medisoft Mobile

Technical problems with Medisoft.
Post Reply
mbpros
Posts: 274
Joined: Fri Mar 11, 2011 6:59 pm

Problem with Medisoft Mobile

Post by mbpros » Mon Apr 08, 2019 2:41 pm

My clients have not used Medisoft Mobile in a long time, but I wanted to test it so I could offer it again. But I'm having a problem. On the app I added a practice without a problem....But when I went to log in I received an error message about the server not being available.

I tested the API Key and Code in Medisoft itself under Tools and had no problem connecting. I have the eMDs MSL Connectivity Service running. So I have no idea what the issue is. Is it possible a certain port has to be open and I don't have that port open on my firewall???

And I assume the old McKesson Diagnose Mobile is no longer used, right?

Thanks,
Steve
Steven Zats
Medical Billing Professionals

User avatar
Gavin Walker
Posts: 4301
Joined: Wed Apr 04, 2007 10:11 pm
Location: Springfield, MO
Contact:

Re: Problem with Medisoft Mobile

Post by Gavin Walker » Tue Apr 09, 2019 8:04 am

We have found that the eMDs MSL Service just stops working every now and then even though it is still running. Restarting the service seems to get it unstuck. We wrote a batch file to restart the service and then we run it on Windows task scheduler to restart the service every morning. No one has complained about this once we have it setup for them.

The McKesson MSL service can be set to Manual startup so it doesn't run anymore.
Gavin Walker
Walker Tek Solutions, LLC
866-890-6777
417-890-6777

mbpros
Posts: 274
Joined: Fri Mar 11, 2011 6:59 pm

Re: Problem with Medisoft Mobile

Post by mbpros » Thu Apr 11, 2019 12:51 pm

Tried it and it didn't help...same error as before. Plus now I don't have the menu options under Tools/Services for the Mobile to obtain the API Key and Code. Any other ideas??

Steve
Steven Zats
Medical Billing Professionals

mbpros
Posts: 274
Joined: Fri Mar 11, 2011 6:59 pm

Re: Problem with Medisoft Mobile

Post by mbpros » Thu Apr 11, 2019 2:47 pm

Regarding the above I now have the menu item back for Mobile Interface Configuration. I am still receiving the same error as before. And when I go into the Mobile Interface Configuration for a new practice it is Disabled. I click Enable and it says Unable to Allocate a New API Key. I did test on my server connectivity by going to https://mslconnect.emds.com/connectiontest and it was successful.

So first what can I do about resolving this error from the app about the server not being available and second what can I do for a new practice when it says Unable to Allocate a New API Key?

Steve
Steven Zats
Medical Billing Professionals

User avatar
Gavin Walker
Posts: 4301
Joined: Wed Apr 04, 2007 10:11 pm
Location: Springfield, MO
Contact:

Re: Problem with Medisoft Mobile

Post by Gavin Walker » Fri Apr 12, 2019 7:47 am

Make sure you only have 1 Medidata root folder and each practice database is listed in the practice list once.

mbpros
Posts: 274
Joined: Fri Mar 11, 2011 6:59 pm

Re: Problem with Medisoft Mobile

Post by mbpros » Fri Apr 12, 2019 3:19 pm

I do have only one root folder and each practice database is listed only once....Any other ideas why in the app I'm getting that the server is not available???
Steven Zats
Medical Billing Professionals

User avatar
Gavin Walker
Posts: 4301
Joined: Wed Apr 04, 2007 10:11 pm
Location: Springfield, MO
Contact:

Re: Problem with Medisoft Mobile

Post by Gavin Walker » Sun Apr 14, 2019 6:37 pm

Steve, we'll need to work with you one on one for this one. Call our office in the morning so we can get a ticket started. 866-890-6777. :mrgreen:

mbpros
Posts: 274
Joined: Fri Mar 11, 2011 6:59 pm

Re: Problem with Medisoft Mobile

Post by mbpros » Mon Apr 15, 2019 2:19 am

Heading out of town for the week to a conference...Will call next week.

Thanks,
Steve
Steven Zats
Medical Billing Professionals

Post Reply